1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
2 # Contributor: Gaetan Bisson <bisson@archlinux.org>
3 # Contributor: Giovanni Scafora <giovanni@archlinux.org>
4 # Contributor: James Rayner <james@archlinux.org>
5 # Contributor: Partha Chowdhury <kira.laucas@gmail.com>
9 _gitcommit=a21a8f7d26f07f1dc5c144be2120e8bc6721159f
11 pkgdesc='Lightweight system monitor for X'
12 url='https://github.com/brndnmtthws/conky'
15 makedepends=('cmake' 'docbook2x' 'docbook-xsl' 'man-db' 'git' 'catch2' 'pandoc' 'python-yaml' 'python-jinja')
17 'glibc' 'glib2' 'lua' 'wireless_tools' 'libxdamage' 'libxinerama' 'libxft' 'imlib2'
18 'libxml2' 'libpulse' 'libxnvctrl' 'systemd-libs' 'ncurses' 'curl'
19 libncursesw.so libXNVCtrl.so libsystemd.so libpulse.so libcurl.so)
20 #source=("git+https://github.com/brndnmtthws/conky.git#commit=${_gitcommit}?signed")
21 #v1.17.0 commit not signed
22 source=("git+https://github.com/brndnmtthws/conky.git#tag=v$pkgver?signed")
26 'EB2E847572A71BE20F59AFBEB49ABB7270D9D4FD' # Brenden Matthews
31 git describe --tags --match 'v*' | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
36 # Unbundle catch2 to fix build with glibc 2.35
38 ln -s /usr/include/catch2 tests
45 -D CMAKE_BUILD_TYPE=Release \
46 -D CMAKE_CXX_FLAGS="$CXXFLAGS -ffat-lto-objects" \
47 -D MAINTAINER_MODE=OFF \
58 -D BUILD_PULSEAUDIO=ON \
60 -D CMAKE_INSTALL_PREFIX=/usr \
69 make -C build DESTDIR="${pkgdir}" install
70 install -Dm 644 COPYING -t "${pkgdir}/usr/share/licenses/${pkgname}"
71 install -Dm 644 build/extras/vim/syntax/conkyrc.vim -t "${pkgdir}"/usr/share/vim/vimfiles/syntax
72 install -Dm 644 extras/vim/ftdetect/conkyrc.vim -t "${pkgdir}"/usr/share/vim/vimfiles/ftdetect