sbcl 2.3.0 rebuild
[arch-packages.git] / facile / trunk / PKGBUILD
blob13fda805f56c73058e49f70a4d2b27b6ac2255db
1 # Maintainer: Tobias Powalowski <tpowa@archlinux.org>
3 pkgname=facile
4 pkgver=1.1.4
5 pkgrel=3
6 pkgdesc="A Functional Constraint Library"
7 arch=(x86_64)
8 url="http://www.recherche.enac.fr/opti/facile/"
9 license=("LGPL")
10 makedepends=('ocaml>=4.14.0' 'ocaml-compiler-libs')
11 depends=()
12 source=(https://github.com/Emmanuel-PLF/facile/archive/$pkgver/$pkgname-$pkgver.tar.gz)
13 sha256sums=('f35cbc3c8022120c01a7b3844b279f032f37856bff1c9801c410f2520e786502')
15 build() {
16   cd $pkgname-$pkgver/lib
17   make
20 package() {
21   cd $pkgname-$pkgver/lib
22   install -Dm644 facile.cmxa facile.cmi facile.cma facile.a -t "$pkgdir/usr/lib/ocaml/facile"