1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
6 pkgdesc="A thin layer of graphic data types"
7 url="https://ebassi.github.io/graphene/"
10 makedepends=(git gtk-doc gobject-introspection meson glib2)
11 checkdepends=(python-gobject python-tappy)
13 _commit=4e2578450809c2099400cf85caf18eafcd7100aa # tags/1.10.8^0
14 source=("git+https://github.com/ebassi/graphene#commit=$_commit"
15 "git+https://github.com/ebassi/mutest"
16 no-installed-tests.diff)
19 'fd7c41b25920077158d7de77f5d073e3a5a215c4d96c3b9bd016ffda615be4c4')
23 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
30 git apply -3 ../no-installed-tests.diff
33 git submodule set-url subprojects/mutest "$srcdir/mutest"
38 arch-meson graphene build \
40 -D installed_tests=false
41 meson compile -C build
45 meson test -C build --print-errorlogs
49 depends=(libg{lib,object}-2.0.so)
50 provides=(libgraphene-1.0.so)
52 meson install -C build --destdir "$pkgdir"
53 install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 graphene/LICENSE.txt