OCaml 5.0.0 rebuild: Fix Pervasives deprecation
[arch-packages.git] / tomcat-native / trunk / PKGBUILD
blob7c9addd9dfd6d6aac300263e7743d4fc6cb254b2
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Guillaume Alaux <guillaume@archlinux.org>
3 # Contributor: Vitaliy Berdinskikh <ur6lad@i.ua>
5 pkgname=tomcat-native
6 pkgver=2.0.3
7 pkgrel=1
8 pkgdesc='Optional component for Tomcat to use certain native resources for performance, compatibility'
9 arch=(x86_64)
10 url=https://tomcat.apache.org/native-doc/
11 license=(APACHE)
12 depends=(
13   apr
14   openssl
16 makedepends=(
17   git
18   java-environment
19   python
21 options=(!emptydirs)
22 _tag=2b617703217b2f94fc51afc0ad30e325f69853a2
23 source=(
24   git+https://github.com/apache/tomcat-native.git#tag=${_tag}
25   tomcat-native-buildconf.patch
27 b2sums=(
28   SKIP
29   d3603079626b908644331c193452088ef3ce89e92c775c60b232d16d04b8c49d40106d55c76f81c87daea93d335868140df0046c7102796d92b08431ac8749a4
32 pkgver() {
33   cd tomcat-native
34   git describe --tags
37 prepare() {
38   cd tomcat-native/native
39   patch -Np2 -i ../../tomcat-native-buildconf.patch
40   automake --add-missing --copy --force-missing || true
41   ./buildconf \
42     --with-apr=/usr/share/apr-1
45 build() {
46   cd tomcat-native/native
47   ./configure \
48     --prefix=/usr \
49     --with-apr=/usr/bin/apr-1-config \
50     --with-java-home=/usr/lib/jvm/default \
51     --with-ssl=/usr
52   make
55 package() {
56   make DESTDIR="${pkgdir}" -C tomcat-native/native install
59 # vim: ts=2 sw=2 et: