OCaml 5.0.0 rebuild: Fix Pervasives deprecation
[arch-packages.git] / xdg-desktop-portal / trunk / PKGBUILD
blob50aa91d38dfca3754ed792cd7467c0f001751864
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: BartÅ‚omiej Piotrowski <bpiotrowski@archlinux.org>
3 # Contributor: Patrick Griffis <tingping@tingping.se>
5 pkgname=xdg-desktop-portal
6 pkgver=1.16.0
7 pkgrel=3
8 pkgdesc="Desktop integration portals for sandboxed apps"
9 url="https://github.com/flatpak/xdg-desktop-portal"
10 arch=(x86_64)
11 license=(LGPL)
12 depends=(
13   fuse3
14   gdk-pixbuf2
15   geoclue
16   glib2
17   pipewire
18   rtkit
19   systemd
21 makedepends=(
22   docbook-xsl
23   flatpak
24   git
25   libportal
26   meson
27   xmlto
29 _commit=88af6c8ca4106fcf70925355350a669848e9fd5a  # tags/1.16.0^0
30 source=("git+https://github.com/flatpak/xdg-desktop-portal#commit=$_commit")
31 b2sums=('SKIP')
33 pkgver() {
34   cd $pkgname
35   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
38 prepare() {
39   cd $pkgname
41   # https://gitlab.gnome.org/GNOME/xdg-desktop-portal-gnome/-/issues/74
42   # https://github.com/flatpak/xdg-desktop-portal/pull/985
43   git cherry-pick -n 2a219279997c2124c8a639b0d009c9946ec97b40
46 build() {
47   arch-meson $pkgname build
48   meson compile -C build
51 check() {
52   meson test -C build --print-errorlogs
55 package() {
56   depends+=(xdg-desktop-portal-impl)
58   meson install -C build --destdir "$pkgdir"
61 # vim:set sw=2 sts=-1 et: