db-move: moved grilo-plugins from [staging] to [testing] (x86_64)
[arch-packages.git] / polkit-qt / repos / extra-x86_64 / PKGBUILD
blob3a17766a41a7aa859597173ba86fe8f5c7aea07a
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Andrea Scarpino <andrea@archlinux.org>
3 # Contributor: Pierre Schmitz <pierre@archlinux.de>
5 pkgbase=polkit-qt
6 pkgname=(polkit-qt5)
7 pkgver=0.114.0
8 pkgrel=1
9 pkgdesc='A library that allows developers to access PolicyKit API with a nice Qt-style API'
10 arch=(x86_64)
11 url='https://www.kde.org/'
12 license=(LGPL)
13 depends=(polkit qt5-base)
14 makedepends=(cmake)
15 source=(https://download.kde.org/stable/$pkgbase-1/$pkgbase-1-$pkgver.tar.xz{,.sig})
16 sha256sums=('2eb0f22445888295ffa2bfbc0c3693847a0f973bb6b0c3e4cce0218be7e3907e'
17             'SKIP')
18 validpgpkeys=(D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heirecka@exherbo.org>
20 build() {
21   cmake -B build -S $pkgbase-1-$pkgver \
22     -DCMAKE_INSTALL_PREFIX=/usr
23   cmake --build build
26 package_polkit-qt5() {
27   DESTDIR="$pkgdir" cmake --install build