OCaml 4.14.0 rebuild
[arch-packages.git] / gnome-klotski / trunk / PKGBUILD
blobc0d6453345f1a04e8e0f5cf9ca58ac2b0d26b97f
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=gnome-klotski
5 pkgver=3.38.2
6 pkgrel=1
7 pkgdesc="Slide blocks to solve the puzzle"
8 url="https://wiki.gnome.org/Apps/Klotski"
9 arch=(x86_64)
10 license=(GPL)
11 depends=(gtk3 librsvg libgnome-games-support)
12 makedepends=(meson gobject-introspection yelp-tools appstream-glib vala git)
13 groups=(gnome-extra)
14 _commit=32d1c953fa49a6b0281b00ea449020027f3f2659  # tags/3.38.2^0
15 source=("git+https://gitlab.gnome.org/GNOME/gnome-klotski.git#commit=$_commit")
16 sha256sums=('SKIP')
18 pkgver() {
19   cd $pkgname
20   git describe --tags | sed 's/-/+/g'
23 prepare() {
24   cd $pkgname
27 build() {
28   arch-meson $pkgname build
29   meson compile -C build
32 check() {
33   meson test -C build --print-errorlogs
36 package() {
37   DESTDIR="$pkgdir" meson install -C build