OCaml 4.14.0 rebuild
[arch-packages.git] / zenity / repos / extra-x86_64 / PKGBUILD
blob44a6f03df9c37ef1c9c75e0ed0878b5fe8cc4571
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=zenity
5 pkgver=3.43.0
6 pkgrel=1
7 pkgdesc="Display graphical dialog boxes from shell scripts"
8 url="https://gitlab.gnome.org/GNOME/zenity"
9 arch=(x86_64)
10 license=(LGPL)
11 depends=(webkit2gtk-4.1 libnotify)
12 makedepends=(yelp-tools meson git)
13 options=(debug)
14 _commit=01e6d92f23f49414ba8ec4c5b3daf49222c1e31d  # tags/3.43.0^0
15 source=("git+https://gitlab.gnome.org/GNOME/zenity.git#commit=$_commit")
16 sha256sums=('SKIP')
18 pkgver() {
19   cd zenity
20   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
23 prepare() {
24   cd zenity
27 build() {
28   arch-meson zenity build \
29     -D libnotify=true \
30     -D webkitgtk=true
31   meson compile -C build
34 check() {
35   meson test -C build --print-errorlogs
38 package() {
39   meson install -C build --destdir "$pkgdir"