1 # Maintainer: David Runge <dvzrv@archlinux.org>
2 # Contributor: Tobias Powalowski <tpowa@archlinux.org>
3 # Contributor: Keshav Amburay <(the ddoott ridikulus ddoott rat) (aatt) (gemmaeiil) (ddoott) (ccoomm)>
6 pkgdesc="Tools and libraries to work with EFI variables"
10 url="https://github.com/rhboot/efivar"
13 makedepends=(git mandoc)
15 provides=(libefiboot.so libefisec.so libefivar.so)
16 # LTO has the linker segfaulting with binutils < 2.38.0: https://github.com/rhboot/efivar/issues/196
19 "git+https://github.com/rhinstaller/efivar.git#tag=${pkgver}?signed"
20 "${pkgname}-38-ld_t.patch::https://github.com/rhboot/efivar/pull/201/commits/197a0874ea4010061b98b4b55eff65b33b1cd741.patch"
23 '568bc88b182875c37479c49b3dbf5b8ee6edf8090f940176e67c9aa28dd2ff6f417c70b2bef6b5df99ada2afa33db3efd295ba9de5d68b3ecc5ce1dc3361d042')
25 'ccddc04ab83d4dcf570d5a89e43fc27d36e2010513b36d9eb2fcdea71ceb5dba96a064a1cbca9ffdecf17fb5b9cb22cfe89eae4ee3a188547a4ab6fa6b4e2983')
26 validpgpkeys=('B00B48BC731AA8840FED9FB0EED266B70F4FEF10') # Peter Jones <pjones@redhat.com>
30 # fix issues with linker scripts: https://github.com/rhboot/efivar/pull/201
31 patch -Np1 -i ../"${pkgname}-38-ld_t.patch"
35 # disable -Werror by default by setting ERRORS to empty string
36 make ERRORS='' all -C "${pkgname}"
40 make GRUB_PREFIX=grub test -k -C "${pkgname}" || echo "grub related tests are flaky"
44 make DESTDIR="${pkgdir}/" \
47 mandir=/usr/share/man/ \
48 includedir=/usr/include/ \
51 install -vDm 644 "${pkgname}/"{README.md,TODO} -t "${pkgdir}/usr/share/doc/${pkgname}"