1 # Maintainer: AndyRTR <andyrtr@archlinux.org>
6 pkgdesc="a C/C++ client library for the CMIS protocol"
8 url="https://github.com/tdf/libcmis"
9 license=('GPL2' 'LGPL2.1' 'MPL')
10 depends=('boost-libs' 'curl' 'libxml2')
11 makedepends=('docbook2x' 'cppunit' 'boost')
12 source=("https://github.com/tdf/libcmis/releases/download/v${pkgver}/$pkgname-$pkgver.tar.gz"
13 libcmis-0.5.2-icu-64.2.patch
15 sha256sums=('ed6f681a48abbf3c2324564b17a180d21fa9503230e8708825e1ad80daee4f81'
16 '51b67a5b7245e5192739362c5034ed7d9a664799f38ff9ccd1832297f93cc03d'
17 '7ad0e742da2660c238b457ea7cd5752b90bb876da3da852f511a6bb1301c75b6')
22 # https://github.com/tdf/libcmis/issues/35
23 patch -Np1 -i ../libcmis-0.5.2-icu-64.2.patch
24 # part of https://github.com/tdf/libcmis/commit/f7466a849949f987dd47f2e0bb3a3df0c8cac4e4
25 # to solve a LibreOffice compile error
26 patch -Np1 -i ../getRefreshToken.diff
31 ./configure --prefix=/usr DOCBOOK2MAN='db2x_docbook2man' --disable-werror
32 sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
38 # fails a google drive check - fix will be included in the next release
39 make check || /bin/true
44 make DESTDIR="$pkgdir/" install