archrelease: copy trunk to extra-x86_64
[arch-packages.git] / qt6-location / kde-unstable / PKGBUILD
blob9aace5ab1546a0e02652175f74234f024c0a88e2
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
4 pkgname=qt6-location
5 _qtver=6.5.0-beta1
6 pkgver=${_qtver/-/}
7 pkgrel=1
8 arch=(x86_64)
9 url='https://www.qt.io'
10 license=(GPL3 LGPL3 FDL custom)
11 pkgdesc='Helps you create viable mapping solutions using the data available from some of the popular location services'
12 depends=(qt6-declarative qt6-positioning)
13 makedepends=(cmake ninja qt6-shadertools)
14 groups=(qt6)
15 options=(debug)
16 _pkgfn=${pkgname/6-/}-everywhere-src-$_qtver
17 source=(https://download.qt.io/development_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz)
18 sha256sums=('1a7a809c723cf63b004991195b5f8e3836ebf1b5bbe00d25d1618504acabaf5a')
20 build() {
21   cmake -B build -S $_pkgfn -G Ninja \
22     -DCMAKE_MESSAGE_LOG_LEVEL=STATUS
23   cmake --build build
26 package() {
27   DESTDIR="$pkgdir" cmake --install build
29   install -d "$pkgdir"/usr/share/licenses
30   ln -s /usr/share/licenses/qt6-base "$pkgdir"/usr/share/licenses/$pkgname