archrelease: copy trunk to extra-x86_64
[arch-packages.git] / syndication / trunk / PKGBUILD
blob650673917a4786920e9f5671c2535a0fa4ac3611
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=syndication
4 pkgver=5.101.0
5 pkgrel=1
6 pkgdesc='RSS/Atom parser library'
7 arch=(x86_64)
8 url='https://community.kde.org/Frameworks'
9 license=(LGPL)
10 depends=(kcodecs)
11 makedepends=(extra-cmake-modules doxygen qt5-tools qt5-doc)
12 groups=(kf5)
13 conflicts=(kde-syndication)
14 provides=(kde-syndication)
15 replaces=(kde-syndication)
16 source=(https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz{,.sig})
17 sha256sums=('c005c3393f17a89f2a467ad7c38cd06e8beb4c67a281e9344a7a909bdd84e2c1'
18             'SKIP')
19 validpgpkeys=(53E6B47B45CEA3E0D5B7457758D0EE648A48B3BB) # David Faure <faure@kde.org>
20 options=(debug)
22 build() {
23   cmake -B build -S $pkgname-$pkgver \
24     -DBUILD_TESTING=OFF \
25     -DBUILD_QCH=ON
26   cmake --build build
29 package() {
30   DESTDIR="$pkgdir" cmake --install build