archrelease: copy trunk to extra-x86_64
[arch-packages.git] / kactivities-stats / repos / extra-x86_64 / PKGBUILD
blobec370957b022a21fefc838a48e8e16d91e81ed78
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=kactivities-stats
6 pkgver=5.96.0
7 pkgrel=1
8 arch=(x86_64)
9 pkgdesc='A library for accessing the usage data collected by the activities system'
10 url='https://community.kde.org/Frameworks'
11 license=(LGPL)
12 depends=(kactivities)
13 makedepends=(extra-cmake-modules doxygen qt5-tools qt5-doc)
14 groups=(kf5)
15 source=(https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz{,.sig})
16 sha256sums=('da9c220a6cf7c8ec64db4cca1f642066f9c403c904bea3802efd9f55cab6ca51'
17             'SKIP')
18 validpgpkeys=(53E6B47B45CEA3E0D5B7457758D0EE648A48B3BB) # David Faure <faure@kde.org>
19 options=(debug)
21 build() {
22   cmake -B build -S $pkgname-$pkgver \
23     -DBUILD_TESTING=OFF \
24     -DBUILD_QCH=ON
25   cmake --build build
28 package() {
29   DESTDIR="$pkgdir" cmake --install build