archrelease: copy trunk to extra-x86_64
[arch-packages.git] / khelpcenter / kde-unstable / PKGBUILD
blobb37198c5a062b91cd2ebaf8205bb56f7c42ec669
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=khelpcenter
6 pkgver=22.07.90
7 pkgrel=1
8 pkgdesc='Application to show KDE Applications documentation'
9 arch=(x86_64)
10 url='https://apps.kde.org/help/'
11 license=(LGPL)
12 groups=(kde-applications kde-system)
13 depends=(khtml kdoctools xapian-core grantlee perl)
14 makedepends=(extra-cmake-modules)
15 source=(https://download.kde.org/unstable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz{,.sig})
16 sha256sums=('3d3a21475ed76559bd851d315825caa3816e686eb96f31b60a3c4a7620745b9f'
17             'SKIP')
18 validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7  # Albert Astals Cid <aacid@kde.org>
19               F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87  # Christoph Feck <cfeck@kde.org>
20               D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
21 options=(debug)
23 build() {
24   cmake -B build -S $pkgname-$pkgver \
25     -DCMAKE_INSTALL_LIBEXECDIR=lib \
26     -DBUILD_TESTING=OFF
27   cmake --build build
30 package() {
31   DESTDIR="$pkgdir" cmake --install build