1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=perl-dbd-sqlite
6 pkgdesc="Self-contained RDBMS in a DBI driver"
8 url="https://search.cpan.org/dist/DBD-SQLite"
9 license=('GPL' 'PerlArtistic')
10 depends=('perl-dbi' 'sqlite')
11 source=("https://www.cpan.org/authors/id/I/IS/ISHIGAKI/DBD-SQLite-$pkgver.tar.gz"
12 $pkgname-sqlite-3.37.patch::https://github.com/DBD-SQLite/DBD-SQLite/commit/ba4f472e7372.patch
14 sha512sums=('163d53a8a214202a39b346ae023f9d10255c69dde537bc764a4ef312b62ef7b02ae1400e6c1a59d0483fd98abba6c36939214c13f5d9b3a2727c41753ba59060'
15 'ed468728a6a1d1e7228ccb8df9fd14ad0c22ae7b5e1b9e7bb32352e4e34794684bcd570da322a94f34e8e967d6155520c4f4652c0ec2f4d0fc0aee6f89314ec7'
16 'cf492402f9127c40130c052a6b3f78e86abc0342385130be386aa12e23b1166f20deac50eee1dcc1e43598ba5785d0a218f2cb0a6bb7f5dd7f7c0fc3220bd2bb')
21 # Ensure that we can never ever build this. If the perl module links against
22 # the system lib this won't matter, if it does not, it will fail during
26 # https://github.com/DBD-SQLite/DBD-SQLite/issues/92
27 patch -Np1 -i ../$pkgname-sqlite-3.37.patch
29 # Makefile asks us to patch this to allow to link with system sqlite...
30 patch -i "$srcdir/libsqlite.patch"
36 # USE_LOCAL_SQLITE=0 disables use of the bundled sqlite
37 perl Makefile.PL INSTALLDIRS=vendor USE_LOCAL_SQLITE=0
48 make install DESTDIR="$pkgdir"