archrelease: copy trunk to extra-x86_64
[arch-packages.git] / python-cson / trunk / PKGBUILD
blobe4bd64dad005add5a3256afc8bbc1c75adb8c3c1
1 # Maintainer: Rémy Oudompheng <remy@archlinux.org>
3 pkgname=python-cson
4 pkgver=0.8
5 pkgrel=5
6 pkgdesc="A Python parser for Coffeescript Object Notation (CSON)"
7 arch=('any')
8 url="https://github.com/avakar/pycson"
9 license=('MIT')
10 makedepends=('git'
11              'python-setuptools'
12              'python-pytest'
13              'python-pytest-cov'
14              'python-speg')
15 depends=('python' 'python-six' 'python-speg')
16 _commit=d2ed07d980382e44726cf3c074957e752ef6441b
17 source=("git+https://github.com/avakar/pycson.git#tag=${_commit}")
18 sha256sums=(SKIP)
20 check() {
21   cd "$srcdir"/pycson
22   PYTHONPATH=. py.test --cov=cson --cov-report term-missing
25 package() {
26   cd "$srcdir"/pycson
27   python setup.py install --root="${pkgdir}"
28   install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"