archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gnome-2048 / trunk / PKGBUILD
blobd447a302881523a80eb45fe97f4930ae73e1f9c9
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=gnome-2048
4 pkgver=3.38.2
5 pkgrel=1
6 pkgdesc="Obtain the 2048 tile"
7 url="https://wiki.gnome.org/Apps/2048"
8 arch=(x86_64)
9 license=(GPL3)
10 depends=(clutter-gtk libgee libgnome-games-support)
11 makedepends=(meson vala yelp-tools appstream-glib git)
12 _commit=82f155f326a9e1973d7283bfa3f7cbb756a9984a  # tags/3.38.2^0
13 source=("git+https://gitlab.gnome.org/GNOME/gnome-2048.git#commit=$_commit")
14 sha256sums=('SKIP')
16 pkgver() {
17   cd $pkgname
18   git describe --tags | sed 's/-/+/g'
21 prepare() {
22   cd $pkgname
25 build() {
26   arch-meson $pkgname build
27   meson compile -C build
30 check() {
31   meson test -C build --print-errorlogs
34 package() {
35   DESTDIR="$pkgdir" meson install -C build