1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Guillaume ALAUX <guillaume@archlinux.org>
4 pkgbase=java-commons-daemon
12 url=https://commons.apache.org/proper/commons-daemon/
14 _tag=0373c020f233236ca7acf4fa4ceef31e27b7cb70
15 source=(git+https://github.com/apache/commons-daemon.git#tag=${_tag})
26 cd commons-daemon/src/native/unix
32 git describe --tags | sed 's/^rel\/commons-daemon-//; s/_RC.*$//; s/_/./g'
40 --with-java=/usr/lib/jvm/default
42 db2x_docbook2man man/jsvc.1.xml
45 package_java-commons-daemon() {
46 pkgdesc='Alternative invocation mechanism for unix-daemon-like java code'
47 depends=(java-runtime)
50 install -Dm 644 target/commons-daemon-${pkgver}.jar -t "${pkgdir}"/usr/share/java/
51 ln -s commons-daemon-${pkgver}.jar "${pkgdir}"/usr/share/java/commons-daemon.jar
55 pkgdesc='Apache application for making Java applications run on UNIX more easily'
61 cd commons-daemon/src/native/unix
62 install -Dm 755 jsvc -t "${pkgdir}"/usr/bin/
63 install -Dm 644 JSVC.1 -t "${pkgdir}"/usr/share/man/man1/