sbcl rebuild
[arch-packages.git] / libhttpseverywhere / trunk / PKGBUILD
blobdd129e4cea2754dd40c4cab94720864f33c6db5d
1 # Maintainer: Jan de Groot <jgc@archlinux.org>
2 # Contributor: AdriĆ  Arrufat (archdria) <adria dot arrufat at protonmail ldot ch>
4 pkgname=libhttpseverywhere
5 pkgver=0.8.2
6 pkgrel=1
7 pkgdesc="Leverage the power of HTTPS Everywhere"
8 url="https://git.gnome.org/browse/libhttpseverywhere"
9 arch=(x86_64)
10 license=(LGPL3)
11 depends=(libgee libxml2 libarchive libsoup glib2 json-glib)
12 makedepends=(meson vala gobject-introspection git)
13 _commit=905a79559ee01aa2c3d591cba6982cb5cf811216  # tags/0.8.2^0
14 source=("git+https://git.gnome.org/browse/libhttpseverywhere#commit=$_commit")
15 sha256sums=('SKIP')
17 pkgver() {
18   cd $pkgname
19   git describe --tags | sed 's/-/+/g'
22 prepare() {
23   cd $pkgname
26 build() {
27   arch-meson $pkgname build -Denable_valadoc=true
28   ninja -C build
31 check() {
32   cd build
33   meson test
36 package() {
37   DESTDIR="$pkgdir" ninja -C build install