1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Anatol Pomozov <anatol.pomozov@gmail.com>
3 # Contributor: Joel Teichroeb <joel@teichroeb.net>
4 # Contributor: Jonas Heinrich <onny@project-insanity.org>
6 pkgname=double-conversion
9 pkgdesc='Binary-decimal and decimal-binary routines for IEEE doubles'
11 url='https://github.com/google/double-conversion'
15 source=(https://github.com/google/double-conversion/archive/v$pkgver/$pkgname-$pkgver.tar.gz)
16 sha256sums=('8a79e87d02ce1333c9d6c5e47f452596442a343d8c3e9b234e8a62fce1b1d49c')
19 cmake -B build -S $pkgname-$pkgver \
20 -DCMAKE_INSTALL_PREFIX=/usr \
21 -DBUILD_SHARED_LIBS=ON
26 DESTDIR="$pkgdir" cmake --install build
28 install -Dm644 $pkgname-$pkgver/LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname