archrelease: copy trunk to extra-x86_64
[arch-packages.git] / findutils / trunk / PKGBUILD
bloba261baca871c013f48b7d5bbd64c27fa56fd740c
1 # Maintainer:
3 pkgname=findutils
4 pkgver=4.8.0
5 pkgrel=1
6 pkgdesc="GNU utilities to locate files"
7 arch=('x86_64')
8 license=('GPL3')
9 groups=('base-devel')
10 depends=('glibc' 'sh')
11 url='https://www.gnu.org/software/findutils/'
12 source=("https://ftp.gnu.org/pub/gnu/findutils/${pkgname}-${pkgver}.tar.xz"{,.sig})
13 sha1sums=('b702a37d3a33038102659777ba1fe99835bb19fe'
14           'SKIP')
15 validpgpkeys=('A5189DB69C1164D33002936646502EF796917195') # Bernhard Voelker <mail@bernhard-voelker.de>
17 build() {
18   cd ${pkgname}-${pkgver}
20   # Don't build or install locate because we use mlocate,
21   # which is a secure version of locate.
22   sed -e '/^SUBDIRS/s/locate//' -e 's/frcode locate updatedb//' -i Makefile.in
24   ./configure --prefix=/usr
25   # don't build locate, but the docs want a file in there.
26   make -C locate dblocation.texi
27   make
30 check() {
31   cd ${pkgname}-${pkgver}
32   make check
35 package() {
36   cd ${pkgname}-${pkgver}
37   make DESTDIR="$pkgdir" install