1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan De Groot <jgc@archlinux.org>
8 pkgdesc="Stores passwords and encryption keys"
9 url="https://wiki.gnome.org/Projects/GnomeKeyring"
12 depends=(gcr libcap-ng pam openssh)
13 makedepends=(git docbook-xsl python)
14 provides=(org.freedesktop.secrets)
16 install=gnome-keyring.install
17 _commit=a9c867468b86719afc9fb62479dc5c48244f5926 # tags/40.0^0
18 source=("git+https://gitlab.gnome.org/GNOME/gnome-keyring.git#commit=$_commit"
21 'd05210f5b0a7d4b22c0dff2854854af2eb5708aa2b296095e070dca68e9f815a')
25 git describe --tags | sed 's/-/+/g'
31 # Autolaunch in Cinnamon
32 git apply -3 ../add-cinnamon.diff
34 NOCONFIGURE=1 ./autogen.sh
39 ./configure --prefix=/usr \
41 --localstatedir=/var \
42 --libexecdir=/usr/lib \
43 --with-pam-dir=/usr/lib/security \
45 --disable-schemas-compile
46 sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
52 # Secure memory tests fail
53 dbus-run-session make -k check || :
58 make DESTDIR="$pkgdir" install