archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gnome-keyring / trunk / PKGBUILD
blob3f971adb9853d517917f458882e972ced1aa2018
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan De Groot <jgc@archlinux.org>
4 pkgname=gnome-keyring
5 pkgver=40.0
6 pkgrel=1
7 epoch=1
8 pkgdesc="Stores passwords and encryption keys"
9 url="https://wiki.gnome.org/Projects/GnomeKeyring"
10 arch=(x86_64)
11 license=(GPL LGPL)
12 depends=(gcr libcap-ng pam openssh)
13 makedepends=(git docbook-xsl python)
14 provides=(org.freedesktop.secrets)
15 groups=(gnome)
16 install=gnome-keyring.install
17 _commit=a9c867468b86719afc9fb62479dc5c48244f5926  # tags/40.0^0
18 source=("git+https://gitlab.gnome.org/GNOME/gnome-keyring.git#commit=$_commit"
19         add-cinnamon.diff)
20 sha256sums=('SKIP'
21             'd05210f5b0a7d4b22c0dff2854854af2eb5708aa2b296095e070dca68e9f815a')
23 pkgver() {
24   cd $pkgname
25   git describe --tags | sed 's/-/+/g'
28 prepare() {
29   cd $pkgname
31   # Autolaunch in Cinnamon
32   git apply -3 ../add-cinnamon.diff
34   NOCONFIGURE=1 ./autogen.sh
37 build() {
38   cd $pkgname
39   ./configure --prefix=/usr \
40     --sysconfdir=/etc \
41     --localstatedir=/var \
42     --libexecdir=/usr/lib \
43     --with-pam-dir=/usr/lib/security \
44     --disable-static \
45     --disable-schemas-compile
46   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
47   make
50 check() {
51   cd $pkgname
52   # Secure memory tests fail
53   dbus-run-session make -k check || :
56 package() {
57   cd $pkgname
58   make DESTDIR="$pkgdir" install