archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libgee / trunk / PKGBUILD
blob6e2e4a02751d0bf5ffd3192f06786a969b745e30
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
3 # Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
5 pkgname=libgee
6 pkgver=0.20.4
7 pkgrel=1
8 pkgdesc="A collection library providing GObject-based interfaces and classes for commonly used data structures"
9 url="https://git.gnome.org/browse/libgee"
10 license=(LGPL2.1)
11 arch=(x86_64)
12 depends=(glib2)
13 makedepends=(gobject-introspection vala autoconf-archive git)
14 _commit=db2efd468d32832ed787165ddda555706d888aca  # tags/0.20.4^0
15 source=("git+https://gitlab.gnome.org/GNOME/libgee.git#commit=$_commit")
16 sha256sums=('SKIP')
18 pkgver() {
19   cd $pkgname
20   git describe --tags | sed 's/-/+/g'
23 prepare() {
24   cd $pkgname
25   NOCONFIGURE=1 ./autogen.sh
28 build() {
29   cd $pkgname
30   ./configure --prefix=/usr --disable-static
31   make
34 check() {
35   cd $pkgname
36   # generates a bazillion traps - make sure systemd's core_pattern
37   # is deactivated, or you'll DoS the journal and the system
38   #make check
41 package() {
42   cd $pkgname
43   make DESTDIR="$pkgdir" install