1 # Maintainer: David Runge <dvzrv@archlinux.org>
2 # Contributor: judd <jvinet@zeroflux.org>
7 pkgdesc="OSS compatibility library"
9 url="https://www.alsa-project.org"
12 makedepends=(alsa-lib)
14 optdepends=('bash: for aoss')
15 provides=(libaoss.so libalsatoss.so)
16 source=("https://www.alsa-project.org/files/pub/oss-lib/$pkgname-$pkgver.tar.bz2"{,.sig})
17 sha512sums=('42966af0ca1be33b4ab1e20b2e3320056ad6caf6ecc5ecde3ae19571809a2fa924dd91d9b2a5d5b6f345b29d937b079400d2a165dbe2b8a33b857cd406c4ac7c'
19 b2sums=('47124c4edd14878b202e6ff6866b5441ffa0991ac3011a3db1efcd1dd2a0c27c9f2b8b38c2a51e8b46cb5714a97393a462154cdfaf89f1238244f7b2635a7740'
21 validpgpkeys=(F04DF50737AC1A884C4B3D718380596DA6E59C91) # ALSA Release Team (Package Signing Key v1) <release@alsa-project.org>
29 # prevent static lib mangling with LTO
30 CFLAGS+=" -ffat-lto-objects"
33 ./configure --prefix=/usr
34 # prevent excessive overlinking due to libtool
35 sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
39 # test requires the oss package and /dev/dsp
41 # cd "$pkgname-$pkgver"
47 depends+=(libasound.so)
50 make DESTDIR="$pkgdir" install