archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gnome-info-collect / repos / extra-any / PKGBUILD
blobfccf0c1a23d03374983f484a912a78a308929507
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=gnome-info-collect
4 pkgver=1.0
5 pkgrel=1
6 pkgdesc="GNOME system and user data collection tool"
7 url="https://gitlab.gnome.org/vstanek/gnome-info-collect"
8 arch=(any)
9 license=(GPL3)
10 depends=(python-requests python-gobject gnome-online-accounts)
11 makedepends=(git)
12 _commit=a0f67581a5b5c63b299a8923f67e4e91dd133106  # tags/v1.0^0
13 source=("git+https://gitlab.gnome.org/vstanek/gnome-info-collect.git#commit=$_commit")
14 sha256sums=('SKIP')
16 pkgver() {
17   cd $pkgname
18   git describe --tags | sed 's/^v//;s/[^-]*-g/r&/;s/-/+/g'
21 package() {
22   install -D $pkgname/client/client.py "$pkgdir/usr/bin/$pkgname"