archrelease: copy trunk to extra-x86_64
[arch-packages.git] / iputils / trunk / PKGBUILD
blobd2e55f05e010478b8b2cd29c9b4054458caaea8a
1 # Maintainer: Stéphane Gaudreault <stephane@archlinux.org>
2 # Maintainer: Tobias Powalowski <tpowa@archlinux.org>
3 # Contributor: Aaron Griffin <aaron@archlinux.org>
5 pkgname=iputils
6 # Commit date + git rev-parse --short origin/master
7 _rev=23c3782a
8 pkgver=20211215
9 pkgrel=1
10 pkgdesc="Network monitoring tools, including ping"
11 arch=('x86_64')
12 license=('GPL')
13 url="http://www.skbuff.net/iputils/"
14 depends=('libcap' 'libidn2')
15 makedepends=('perl-sgmls' 'git' 'docbook-xsl' 'meson' 'systemd' 'iproute')
16 conflicts=('netkit-base' 'arping')
17 replaces=('netkit-base')
18 source=("git+https://github.com/iputils/iputils.git#tag=${pkgver}?signed")
19 validpgpkeys=('2016FEA4858B1C36B32E833AC0DEC2EE72F33A5F') # Petr Vorel
20 sha1sums=('SKIP')
22 build() {
23   mkdir -p build
24   cd build
26   arch-meson ../$pkgname -DBUILD_RARPD=true 
27   ninja
30 package() {
31   cd build
33   DESTDIR="$pkgdir" ninja install