archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libcerf / trunk / PKGBUILD
blob246c81e21e87572c248c6dd61516dfeaa7521859
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=libcerf
4 epoch=1
5 pkgver=2.1
6 pkgrel=1
7 pkgdesc='Self-contained numeric library that provides an efficient and accurate implementation of complex error functions'
8 arch=(x86_64)
9 url='https://jugit.fz-juelich.de/mlz/libcerf/'
10 license=(custom)
11 depends=(glibc)
12 makedepends=(cmake)
13 source=(https://jugit.fz-juelich.de/mlz/libcerf/-/archive/v$pkgver/libcerf-v$pkgver.tar.gz)
14 sha256sums=('8a1cd8b7fae04b82a95168252129b8c1baca098a285ff8d3f25781dead14b75a')
16 build() {
17   cmake -B build -S $pkgname-v$pkgver \
18     -DCMAKE_INSTALL_PREFIX=/usr
19   cmake --build build
22 package() {
23   DESTDIR="$pkgdir" cmake --install build
25   install -Dm644 $pkgname-v$pkgver/LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname