archrelease: copy trunk to extra-x86_64
[arch-packages.git] / qt6-imageformats / repos / extra-x86_64 / PKGBUILD
blob885f09d56090709b8cdd8f09e79ef72b93df4748
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=qt6-imageformats
6 _qtver=6.3.0
7 pkgver=${_qtver/-/}
8 pkgrel=1
9 arch=(x86_64)
10 url='https://www.qt.io'
11 license=(GPL3 LGPL3 FDL custom)
12 pkgdesc='Plugins for additional image formats: TIFF, MNG, TGA, WBMP'
13 depends=(qt6-base jasper libwebp libmng)
14 makedepends=(cmake ninja)
15 groups=(qt6)
16 options=(debug)
17 _pkgfn=${pkgname/6-/}-everywhere-src-$_qtver
18 source=(https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz)
19 sha256sums=('025d0d17ed75b42a7eb6b523731ab8f17025421a8810cade25caffe05d93abef')
21 build() {
22   cmake -B build -S $_pkgfn -G Ninja
23   cmake --build build
26 package() {
27   DESTDIR="$pkgdir" cmake --install build
29   install -d "$pkgdir"/usr/share/licenses
30   ln -s /usr/share/licenses/qt6-base "$pkgdir"/usr/share/licenses/$pkgname