archrelease: copy trunk to extra-x86_64
[arch-packages.git] / zenity / trunk / PKGBUILD
blob2335c6e87a9c677525b6a35174346653c551d135
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=zenity
5 pkgver=3.42.1
6 pkgrel=1
7 pkgdesc="Display graphical dialog boxes from shell scripts"
8 url="https://gitlab.gnome.org/GNOME/zenity"
9 arch=(x86_64)
10 license=(LGPL)
11 depends=(webkit2gtk libnotify)
12 makedepends=(yelp-tools meson git)
13 options=(debug)
14 _commit=5aa43ab26e2f2ff5be16daabe15995799ffbaba2  # tags/3.42.1^0
15 source=("git+https://gitlab.gnome.org/GNOME/zenity.git#commit=$_commit")
16 sha256sums=('SKIP')
18 pkgver() {
19   cd zenity
20   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
23 prepare() {
24   cd zenity
27 build() {
28   arch-meson zenity build \
29     -D libnotify=true \
30     -D webkitgtk=true
31   meson compile -C build
34 check() {
35   meson test -C build --print-errorlogs
38 package() {
39   meson install -C build --destdir "$pkgdir"