1 # Maintainer: Evangelos Foutras <evangelos@foutrelis.com>
2 # Contributor: Armin K. <krejzi at email dot com>
7 pkgdesc="Library for binding to C libraries using pure OCaml"
9 url="https://github.com/ocamllabs/ocaml-ctypes"
11 depends=('ocaml>=4.13.1' 'libffi' 'ocaml-integers')
12 makedepends=('ocaml-findlib' 'ocaml-compiler-libs')
13 options=('!strip' '!makeflags')
14 source=($pkgname-$pkgver.tar.gz::https://github.com/ocamllabs/ocaml-ctypes/archive/$pkgver.tar.gz)
15 sha512sums=('1e197009f7e6b29b43944f757e987934337ebfa11bb2ff2ca8ba3ebc607e37cf1259d07a90d7faf4b91b49ee20d5c65357ad305f34ada0a8d336a3904233150e')
18 cd "$srcdir/$pkgname-$pkgver"
23 cd "$srcdir/$pkgname-$pkgver"
25 local _destdir="$pkgdir$(ocamlfind printconf destdir)"
26 install -d "$_destdir/stublibs"
28 make OCAMLFIND_DESTDIR="$_destdir" install
30 install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
33 # vim:set ts=2 sw=2 et: