archrelease: copy trunk to extra-x86_64
[arch-packages.git] / qt6-networkauth / repos / kde-unstable-x86_64 / PKGBUILD
blob14b4eae0310f8c90704917c4dbba7e33f5440f67
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=qt6-networkauth
6 _qtver=6.4.0-beta2
7 pkgver=${_qtver/-/}
8 pkgrel=1
9 arch=(x86_64)
10 url='https://www.qt.io'
11 license=(GPL3 LGPL3 FDL custom)
12 pkgdesc='Network authentication module'
13 depends=(qt6-base)
14 makedepends=(cmake ninja)
15 groups=(qt6)
16 options=(debug)
17 _pkgfn=${pkgname/6-/}-everywhere-src-$_qtver
18 source=(https://download.qt.io/development_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz)
19 sha256sums=('02b4bae0e29ecebb79121bdb10092200eef796cfdd77ef6993a705100f63da4e')
21 build() {
22   cmake -B build -S $_pkgfn -G Ninja \
23     -DCMAKE_MESSAGE_LOG_LEVEL=STATUS
24   cmake --build build
27 package() {
28   DESTDIR="$pkgdir" cmake --install build
30   install -d "$pkgdir"/usr/share/licenses
31   ln -s /usr/share/licenses/qt6-base "$pkgdir"/usr/share/licenses/$pkgname