archrelease: copy trunk to extra-x86_64
[arch-packages.git] / xcb-util-image / trunk / PKGBUILD
blob6f66e62350dd38f7e09934fb9a9b2b6e76b72531
1 # Maintainer: Jan de Groot <jgc@archlinux.org>
2 # Maintainer: Andreas Radke <andyrtr@archlinux.org>
4 pkgname=xcb-util-image
5 pkgver=0.4.0
6 pkgrel=4
7 pkgdesc="Utility libraries for XC Binding - Port of Xlib's XImage and XShmImage functions"
8 arch=('x86_64')
9 url="https://xcb.freedesktop.org"
10 license=('custom')
11 depends=('libxcb>=1.7' 'xcb-util>=0.3.9')
12 makedepends=('xorg-util-macros' 'xorgproto')
13 source=("https://xcb.freedesktop.org/dist/${pkgname}-${pkgver}.tar.bz2")
14 sha512sums=('9b7202c054e1160f9ca97a86be1210d9fb47f2119f89ca85f15f20909cca884bfe0cb88e3e71c75b65e1a0a72b980066ccac810e41a91db895c74dde77440d4f')
16 build() {
17   cd ${pkgname}-${pkgver}
18   ./configure --prefix=/usr --disable-static
19   make
22 check() {
23   cd ${pkgname}-${pkgver}
24   make check
27 package() { 
28   cd ${pkgname}-${pkgver}
29   make DESTDIR="${pkgdir}" install
31   install -D -m644 COPYING \
32     "${pkgdir}"/usr/share/licenses/${pkgname}/COPYING