OCaml 4.13.1 rebuild
[arch-packages.git] / rrdtool / repos / extra-x86_64 / PKGBUILD
blobcb5a32e6c28b1f6ed1471d1c3254177dc09d3d84
1 # Maintainer: Eric BĂ©langer <eric@archlinux.org>
3 pkgname=rrdtool
4 pkgver=1.7.2
5 pkgrel=8
6 pkgdesc="Data logging and graphing application"
7 arch=('x86_64')
8 url="https://www.rrdtool.org"
9 license=('GPL' 'custom')
10 depends=('libxml2' 'pango' 'ttf-dejavu')
11 makedepends=('intltool' 'ruby' 'python-setuptools' 'tcl' 'lua51' 'systemd')
12 optdepends=('perl: to use corresponding binding'
13             'tcl: to use corresponding binding'
14             'python: to use corresponding binding'
15             'ruby: to use corresponding binding'
16             'lua51: to use corresponding binding')
17 options=('!emptydirs' '!makeflags')
18 source=(https://oss.oetiker.ch/rrdtool/pub/rrdtool-${pkgver}.tar.gz)
19 sha256sums=('a199faeb7eff7cafc46fac253e682d833d08932f3db93a550a4a5af180ca58db')
21 prepare() {
22   cd ${pkgname}-${pkgver}
24   # fix FS#28521 make ruby install to vendor_ruby instead of site_ruby
25   sed -e 's/$(RUBY) ${abs_srcdir}\/ruby\/extconf.rb/& --vendor/' -i bindings/Makefile.am
26   aclocal
27   automake
30 build() {
31   cd ${pkgname}-${pkgver}
32   LUA=/usr/bin/lua5.1 \
33     LUA_CFLAGS="-I/usr/include/lua5.1 -llua5.1" LUA_INSTALL_CMOD="/usr/lib/lua/5.1" \
34     ./configure --prefix=/usr --localstatedir=/var --disable-rpath \
35     --enable-perl --enable-perl-site-install --with-perl-options='INSTALLDIRS=vendor' \
36     --enable-ruby --enable-ruby-site-install --enable-python \
37     --enable-lua --enable-lua-site-install --enable-tcl --disable-libwrap
38   make
41 package() {
42   cd ${pkgname}-${pkgver}
43   make DESTDIR="${pkgdir}" includedir=/usr/include install
44   install -D -m644 COPYRIGHT "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"