1 # Maintainer: Eric BĂ©langer <eric@archlinux.org>
6 pkgdesc="Data logging and graphing application"
8 url="https://www.rrdtool.org"
9 license=('GPL' 'custom')
10 depends=('libxml2' 'pango' 'ttf-dejavu')
11 makedepends=('intltool' 'ruby' 'python-setuptools' 'tcl' 'lua51' 'systemd')
12 optdepends=('perl: to use corresponding binding'
13 'tcl: to use corresponding binding'
14 'python: to use corresponding binding'
15 'ruby: to use corresponding binding'
16 'lua51: to use corresponding binding')
17 options=('!emptydirs' '!makeflags')
18 source=(https://oss.oetiker.ch/rrdtool/pub/rrdtool-${pkgver}.tar.gz)
19 sha256sums=('a199faeb7eff7cafc46fac253e682d833d08932f3db93a550a4a5af180ca58db')
22 cd ${pkgname}-${pkgver}
24 # fix FS#28521 make ruby install to vendor_ruby instead of site_ruby
25 sed -e 's/$(RUBY) ${abs_srcdir}\/ruby\/extconf.rb/& --vendor/' -i bindings/Makefile.am
31 cd ${pkgname}-${pkgver}
33 LUA_CFLAGS="-I/usr/include/lua5.1 -llua5.1" LUA_INSTALL_CMOD="/usr/lib/lua/5.1" \
34 ./configure --prefix=/usr --localstatedir=/var --disable-rpath \
35 --enable-perl --enable-perl-site-install --with-perl-options='INSTALLDIRS=vendor' \
36 --enable-ruby --enable-ruby-site-install --enable-python \
37 --enable-lua --enable-lua-site-install --enable-tcl --disable-libwrap
42 cd ${pkgname}-${pkgver}
43 make DESTDIR="${pkgdir}" includedir=/usr/include install
44 install -D -m644 COPYRIGHT "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"