sbcl rebuild
[arch-packages.git] / breezy / trunk / PKGBUILD
blob2baa77beaf93d819ba5153eed70d3e84b8e2f992
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Adam Fontenot <adam.m.fontenot@gmail.com>
4 pkgname=breezy
5 pkgver=3.2.2
6 pkgrel=2
7 pkgdesc='A decentralized revision control system with support for Bazaar and Git file formats'
8 arch=(x86_64)
9 url=https://www.breezy-vcs.org/
10 license=(GPL2)
11 depends=(
12   python-configobj
13   python-fastbencode
14   python-patiencediff
15   python-six
17 makedepends=(
18   cython
19   git
20   python-dulwich
21   python-fastimport
22   python-gpgme
23   python-paramiko
24   python-setuptools
26 checkdepends=(python-testrepository)
27 optdepends=(
28   'python-dulwich: Git support'
29   'python-fastimport: Fastimport support'
30   'python-gpgme: PGP support'
31   'python-paramiko: access branches over SFTP'
33 provides=(bzr)
34 conflicts=(bzr)
35 replaces=(bzr)
36 _tag=7ebf59679d4234f40404b6a565f172a77bef1aea
37 source=(git+https://github.com/breezy-team/breezy.git#tag=${_tag})
38 sha256sums=(SKIP)
40 prepare() {
41   cd breezy
42   sed 's/_script_version = (3, 2, 0)/_script_version = (3, 2, 1)/' -i brz
45 pkgver() {
46   cd breezy
47   git describe --tags | sed 's/brz-//; s/-/./g'
50 build() {
51   cd breezy
52   python setup.py build
55 package() {
56   cd breezy
57   python setup.py install --root="${pkgdir}" --install-data=usr/share --optimize=1 --skip-build
58   ln -s brz "${pkgdir}"/usr/bin/bzr # backwards compatibility
61 # vim: ts=2 sw=2 et: