sbcl rebuild
[arch-packages.git] / lighttpd / trunk / PKGBUILD
blob22a0154ea0e60cce9e040c82cb7e2510372392fb
1 # Maintainer: Pierre Schmitz <pierre@archlinux.de>
3 pkgname=lighttpd
4 pkgver=1.4.66
5 pkgrel=1
6 pkgdesc='A secure, fast, compliant and very flexible web-server'
7 license=('custom')
8 arch=('x86_64')
9 url="https://www.lighttpd.net/"
10 depends=('pcre2' 'util-linux' 'systemd')
11 makedepends=('mariadb-libs' 'lua' 'libxml2' 'e2fsprogs' 'sqlite' 'gdbm' 'pkgconfig')
12 optdepends=('libxml2: mod_webdav'
13             'lua: mod_cml/mod_magnet'
14             'mariadb-libs: mod_mysql_vhost/mod_authn_mysql'
15             'sqlite: mod_webdav')
16 backup=('etc/lighttpd/lighttpd.conf' 'etc/logrotate.d/lighttpd')
17 options=('emptydirs')
18 source=("https://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-${pkgver}.tar.xz"{,.asc}
19         'lighttpd.logrotate.d' 'lighttpd.conf' 'lighttpd.tmpfiles' 'lighttpd.service')
20 sha256sums=('47ac6e60271aa0196e65472d02d019556dc7c6d09df3b65df2c1ab6866348e3b'
21             'SKIP'
22             '41f6c0042bb61021553779f861910e335834f6c15e4411756cdc6233b31076fe'
23             'fece4581bebf39768571962dedce176b2b5f487c0abb5c1cfb35395de216c01f'
24             'd8a185145a7c08b4fd8c8e6c12dae3e176389dd9b1c66e239757b2ba5108c871'
25             '0c88403364e732c06090f6807105dedbac25aa82add0499d28007f8aaa780b78')
26 validpgpkeys=('C7CA1E9E29DC77F5480894B2E0E7D0171E95BAD7'
27               '649D0DD767FF206202A76C5158F14A786FE198C8'
28               'EAAF41A8BE3BB8D001CACD136DE62CA242909B84')
30 build() {
31         cd "$srcdir/$pkgname-$pkgver"
33         ./configure --prefix=/usr \
34                 --sbindir=/usr/bin \
35                 --libdir=/usr/lib/lighttpd/ \
36                 --sysconfdir=/etc/lighttpd \
37                 --with-mysql \
38                 --with-ldap \
39                 --with-attr \
40                 --with-openssl \
41                 --with-webdav-props \
42                 --with-webdav-locks \
43                 --with-gdbm \
44                 --with-lua \
45                 --with-pcre2
46         sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
47         make
50 check() {
51         cd "$srcdir/$pkgname-$pkgver"
52         make check
55 package() {
56         cd "$srcdir/$pkgname-$pkgver"
57         make DESTDIR="$pkgdir" install
59         install -D -m644 "$srcdir/lighttpd.logrotate.d" "$pkgdir/etc/logrotate.d/lighttpd"
60         install -D -m644 "$srcdir/lighttpd.conf" "$pkgdir/etc/lighttpd/lighttpd.conf"
61         install -d -m700 -o http -g http "$pkgdir"/var/{log,cache}/lighttpd/
62         install -D -m644 "${srcdir}/lighttpd.tmpfiles" "${pkgdir}/usr/lib/tmpfiles.d/lighttpd.conf"
63         install -D -m644 "${srcdir}/lighttpd.service" "${pkgdir}/usr/lib/systemd/system/lighttpd.service"
65         pushd doc/config >/dev/null
66         find . -type f ! -name 'Makefile*' -exec install -D -m644 {} "${pkgdir}"/usr/share/doc/lighttpd/config/{} \;
67         popd >/dev/null
69         install -D -m644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"