sbcl rebuild
[arch-packages.git] / pcre / trunk / PKGBUILD
blobd49f39c022d97a6171d72b530fe1fdb79bf16386
1 # Maintainer: Sébastien "Seblu" Luttringer
2 # Contributor: Allan McRae <allan@archlinux.org>
3 # Contributor: Eric Belanger <eric@archlinux.org>
4 # Contributor: John Proctor <jproctor@prium.net>
6 pkgname=pcre
7 pkgver=8.45
8 pkgrel=2
9 pkgdesc='A library that implements Perl 5-style regular expressions'
10 arch=('x86_64')
11 url='https://www.pcre.org/'
12 license=('BSD')
13 depends=('gcc-libs' 'readline' 'zlib' 'bzip2' 'bash')
14 provides=(libpcreposix.so libpcrecpp.so libpcre32.so libpcre16.so libpcre.so)
15 options=(debug staticlibs)
16 source=(https://sourceforge.net/projects/pcre/files/pcre/$pkgver/pcre-$pkgver.tar.bz2{,.sig})
17 sha512sums=('91bff52eed4a2dfc3f3bfdc9c672b88e7e2ffcf3c4b121540af8a4ae8c1ce05178430aa6b8000658b9bb7b4252239357250890e20ceb84b79cdfcde05154061a'
18             'SKIP')
19 validpgpkeys=('45F68D54BBE23FB3039B46E59766E084FB0F43D8') # Philip Hazel
21 prepare() {
22   cd $pkgname-$pkgver
23   # apply patch from the source array (should be a pacman feature)
24   local filename
25   for filename in "${source[@]}"; do
26     if [[ "$filename" =~ \.patch$ ]]; then
27       msg2 "Applying patch ${filename##*/}"
28       patch -p1 -N -i "$srcdir/${filename##*/}"
29     fi
30   done
31   :
34 build() {
35   cd $pkgname-$pkgver
36   ./configure \
37     --prefix=/usr \
38     --enable-unicode-properties \
39     --enable-pcre16 \
40     --enable-pcre32 \
41     --enable-jit \
42     --enable-pcregrep-libz \
43     --enable-pcregrep-libbz2 \
44     --enable-pcretest-libreadline
45   make
48 check() {
49   cd $pkgname-$pkgver
50   make -j1 check
53 package() {
54   cd $pkgname-$pkgver
55   make DESTDIR="$pkgdir" install
57   install -Dm644 LICENCE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
60 # vim:set ts=2 sw=2 et: