1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
3 # Contributor: Alan Young <harleypig@gmail.com>
5 pkgname=perl-module-build
8 pkgdesc="Build, test, and install Perl modules"
10 url="https://search.cpan.org/dist/Module-Build"
11 license=('PerlArtistic' 'GPL')
12 depends=('perl' 'perl-cpan-meta' 'perl-inc-latest')
13 checkdepends=('perl-par-dist' 'perl-archive-zip')
14 options=('!emptydirs')
15 source=(https://search.cpan.org/CPAN/authors/id/L/LE/LEONT/Module-Build-$pkgver.tar.gz)
16 sha512sums=('ee1dc18a7df3fe67e7f954d5e1e071aa0a6f5bce6783b768bceb01f071e64ac8be63f410c932c7c16764e5d4f52fc664ce11a12f26f6afc75a26f79883efad70')
19 cd Module-Build-$pkgver
20 perl Build.PL installdirs=vendor
25 cd Module-Build-$pkgver
30 cd Module-Build-$pkgver
31 perl Build install destdir="$pkgdir"