1 # Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
2 # Maintainer: Jan de Groot <jgc@archlinux.org>
5 pkgname=(python2-gobject2)
8 pkgdesc="Legacy Python 2 bindings for GObject"
9 url="https://wiki.gnome.org/Projects/PyGObject"
12 depends=(glib2 python2)
14 provides=("pygobject2-devel=$pkgver-$pkgrel")
15 conflicts=('pygobject2-devel')
16 replaces=('pygobject2-devel<=2.28.7-3')
17 _commit=c9594b6a91e6ca2086fedec2ed8249e0a9c029fc # tags/PYGOBJECT_2_28_7^0
18 source=("git+https://gitlab.gnome.org/GNOME/pygobject.git#commit=$_commit")
23 git describe --tags | sed 's/^PYGOBJECT_//;s/_/./g;s/-/+/g'
28 find . \( -name '*.py' -o -name '*.py.in' \) -exec sed -i '1s|python$|&2|' {} +
34 CPPFLAGS+=' -Wno-deprecated-declarations'
35 ./configure --prefix=/usr --disable-introspection PYTHON=/usr/bin/python2
36 sed -i 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
40 package_python2-gobject2() {
42 make DESTDIR="$pkgdir" install
43 rm -r "$pkgdir/usr/share/gtk-doc"