1 # Maintainer: Angel Velasquez <angvp@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 # Contributor: Stéphane Gaudreault <stephane@archlinux.org>
4 # Contributor: Allan McRae <allan@archlinux.org>
5 # Contributor: Jason Chu <jason@archlinux.org>
10 pkgname=(python python-tests)
13 _pybasever=${pkgver%.*}
14 pkgdesc="Next generation of the python high-level scripting language"
17 url="https://www.python.org/"
19 depends=('bzip2' 'expat' 'gdbm' 'libffi' 'libnsl' 'libxcrypt' 'openssl' 'zlib')
20 makedepends=('tk' 'sqlite' 'bluez-libs' 'mpdecimal' 'llvm' 'gdb' 'xorg-server-xvfb' 'ttf-font')
21 source=("https://www.python.org/ftp/python/${pkgver%rc*}/Python-${pkgver}.tar.xz"{,.asc})
22 sha512sums=('f2bf424bf4f4caa524ee1248b431e8e06d0745c3fc3ba457710d75f3698e653733feb4b059cd124f1de2a9e851c30d847f567aa47abef12898c9dc8a6507b476'
24 validpgpkeys=('0D96DF4D4110E5C43FBFB17F2D347EA6AA65421D' # Ned Deily (Python release signing key) <nad@python.org>
25 'E3FF2839C048B25C084DEBE9B26995E310250568' # Łukasz Langa (GPG langa.pl) <lukasz@langa.pl>
26 'A035C8C19219BA821ECEA86B64E628F8D684696D') # Pablo Galindo Salgado <pablogsal@gmail.com>
32 sed -i -e "s|^#.* /usr/local/bin/python|#!/usr/bin/python|" Lib/cgi.py
34 # Ensure that we are using the system copy of various libraries (expat, libffi, and libmpdec),
35 # rather than copies shipped in the tarball
37 rm -r Modules/_ctypes/{darwin,libffi}*
38 rm -r Modules/_decimal/libmpdec
44 # PGO should be done with -O3
45 CFLAGS="${CFLAGS/-O2/-O3} -ffat-lto-objects"
47 # Disable bundled pip & setuptools
48 ./configure --prefix=/usr \
50 --with-computed-gotos \
51 --enable-optimizations \
55 --with-dbmliborder=gdbm:ndbm \
57 --with-system-libmpdec \
58 --enable-loadable-sqlite-extensions \
60 --with-tzpath=/usr/share/zoneinfo
62 # Obtain next free server number for xvfb-run; this even works in a chroot environment.
64 while ! xvfb-run -a -n "$servernum" /bin/true 2>/dev/null; do servernum=$((servernum+1)); done
66 LC_CTYPE=en_US.UTF-8 xvfb-run -s "-screen 0 1920x1080x16 -ac +extension GLX" -a -n "$servernum" make EXTRA_CFLAGS="$CFLAGS"
70 # test_socket: test.test_socket.RDSTest.testPeek hangs https://bugs.python.org/issue35247
71 # test_tk: tkinter.test.test_tkinter.test_colorchooser.DefaultRootTest hangs
72 # test_pyexpat: our `debug` implementation rewrites source location, which breaks the build-time
73 # only test test.test_pyexpat.HandlerExceptionTest as it cannot find source file in
74 # the to-be-installed debug package
78 # Obtain next free server number for xvfb-run; this even works in a chroot environment.
80 while ! xvfb-run -a -n "$servernum" /bin/true 2>/dev/null; do servernum=$((servernum+1)); done
82 LD_LIBRARY_PATH="${srcdir}/Python-${pkgver}":${LD_LIBRARY_PATH} \
83 LC_CTYPE=en_US.UTF-8 xvfb-run -s "-screen 0 1920x1080x16 -ac +extension GLX" -a -n "$servernum" \
84 "${srcdir}/Python-${pkgver}/python" -m test.regrtest -v -uall -x test_socket -x test_tk -x test_pyexpat
88 optdepends=('python-setuptools'
91 'mpdecimal: for decimal'
99 # Hack to avoid building again
100 sed -i 's/^all:.*$/all: build_all/' Makefile
102 # PGO should be done with -O3
103 CFLAGS="${CFLAGS/-O2/-O3}"
105 make DESTDIR="${pkgdir}" EXTRA_CFLAGS="$CFLAGS" install
108 rm -r "$pkgdir"/usr/lib/python*/{test,ctypes/test,distutils/tests,idlelib/idle_test,lib2to3/tests,sqlite3/test,tkinter/test,unittest/test}
110 # Why are these not done by default...
111 ln -s python3 "${pkgdir}"/usr/bin/python
112 ln -s python3-config "${pkgdir}"/usr/bin/python-config
113 ln -s idle3 "${pkgdir}"/usr/bin/idle
114 ln -s pydoc3 "${pkgdir}"/usr/bin/pydoc
115 ln -s python${_pybasever}.1 "${pkgdir}"/usr/share/man/man1/python.1
117 # some useful "stuff" FS#46146
118 install -dm755 "${pkgdir}"/usr/lib/python${_pybasever}/Tools/{i18n,scripts}
119 install -m755 Tools/i18n/{msgfmt,pygettext}.py "${pkgdir}"/usr/lib/python${_pybasever}/Tools/i18n/
120 install -m755 Tools/scripts/{README,*py} "${pkgdir}"/usr/lib/python${_pybasever}/Tools/scripts/
123 install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
126 package_python-tests() {
127 pkgdesc="Regression tests packages for Python"
132 make DESTDIR="${pkgdir}" EXTRA_CFLAGS="$CFLAGS" libinstall
133 cd "$pkgdir"/usr/lib/python*/
134 rm -r !(test|ctypes|distutils|idlelib|lib2to3|sqlite3|tkinter|unittest)
135 cd "$pkgdir"/usr/lib/python*/ctypes
137 cd "$pkgdir"/usr/lib/python*/distutils
139 cd "$pkgdir"/usr/lib/python*/idlelib
141 cd "$pkgdir"/usr/lib/python*/lib2to3
143 cd "$pkgdir"/usr/lib/python*/sqlite3
145 cd "$pkgdir"/usr/lib/python*/tkinter
147 cd "$pkgdir"/usr/lib/python*/unittest