1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
9 url='https://www.qt.io'
10 license=(GPL3 LGPL3 FDL custom)
11 pkgdesc='Provides access to hardware and virtual serial ports'
13 makedepends=(cmake ninja)
16 _pkgfn=${pkgname/6-/}-everywhere-src-$_qtver
17 source=(https://download.qt.io/development_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz)
18 sha256sums=('20de5a937b2eb1365f18e971224da44ee58b70d487aa516d91ee193fbd0dd458')
21 cmake -B build -S $_pkgfn -G Ninja \
22 -DCMAKE_MESSAGE_LOG_LEVEL=STATUS
27 DESTDIR="$pkgdir" cmake --install build
29 install -d "$pkgdir"/usr/share/licenses
30 ln -s /usr/share/licenses/qt6-base "$pkgdir"/usr/share/licenses/$pkgname