archrelease: copy trunk to extra-x86_64
[arch-packages.git] / make / trunk / PKGBUILD
blob642e25fdb6e39fa03f974170497d7f1d3e852b79
1 # Maintainer: Lukas Fleischer <lfleischer@archlinux.org>
2 # Contributor: Allan McRae <allan@archlinux.org>
3 # Contributor: judd <jvinet@zeroflux.org>
5 pkgname=make
6 pkgver=4.3
7 pkgrel=3
8 pkgdesc="GNU make utility to maintain groups of programs"
9 arch=('x86_64')
10 url="https://www.gnu.org/software/make"
11 license=('GPL3')
12 groups=('base-devel')
13 depends=('glibc' 'guile')
14 source=("https://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.lz"{,.sig})
15 md5sums=('d5c40e7bd1e97a7404f5d3be982f479a'
16          'SKIP')
17 validpgpkeys=('6D4EEB02AD834703510B117680CB727A20C79BB2')   # Paul Smith
19 build() {
20         cd "${pkgname}-${pkgver}"
21         ./configure --prefix=/usr
22         make
25 check() {
26         cd "${pkgname}-${pkgver}"
27         make -k check
30 package() {
31         cd "${pkgname}-${pkgver}"
32         make DESTDIR="${pkgdir}" install