archrelease: copy trunk to extra-x86_64
[arch-packages.git] / tali / repos / extra-x86_64 / PKGBUILD
blob6965d6c168bf292879b17e7968c80fc13db72db1
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=tali
5 pkgver=40.8
6 pkgrel=1
7 pkgdesc="Beat the odds in a poker-style dice game"
8 url="https://wiki.gnome.org/Apps/Tali"
9 arch=(x86_64)
10 license=(GPL)
11 depends=(gtk3 librsvg libgnome-games-support)
12 makedepends=(meson gobject-introspection yelp-tools appstream-glib git)
13 groups=(gnome-extra)
14 options=(debug)
15 _commit=b83d78d21d4d556f96490caf2be2cc7a58a2ae11  # tags/40.8^0
16 source=("git+https://gitlab.gnome.org/GNOME/tali.git#commit=$_commit")
17 sha256sums=('SKIP')
19 pkgver() {
20   cd tali
21   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
24 prepare() {
25   cd tali
28 build() {
29   arch-meson tali build
30   meson compile -C build
33 check() {
34   meson test -C build --print-errorlogs
37 package() {
38   meson install -C build --destdir "$pkgdir"