db-move: moved gnome-notes from [testing] to [extra] (x86_64)
[arch-packages.git] / gnome-notes / repos / extra-x86_64 / PKGBUILD
blob08e8be126b5e44cf89dbdd24d999c875a89f624c
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=gnome-notes
4 pkgver=40.1
5 pkgrel=4
6 pkgdesc="Write out notes, every detail matters"
7 url="https://wiki.gnome.org/Apps/Notes"
8 arch=(x86_64)
9 license=(GPL)
10 depends=(
11   curl
12   evolution-data-server
13   glib2
14   gnome-online-accounts
15   gtk3
16   json-glib
17   libhandy
18   libxml2
19   tracker3
20   webkit2gtk-4.1
22 makedepends=(
23   git
24   meson
25   yelp-tools
27 provides=("bijiben=$pkgver")
28 conflicts=(bijiben)
29 replaces=(bijiben)
30 groups=(gnome-extra)
31 _commit=b5189e213b50cac50f5602945836dc4d85b17959  # tags/BIJIBEN_40_1^0
32 source=("git+https://gitlab.gnome.org/GNOME/gnome-notes.git#commit=$_commit")
33 b2sums=('SKIP')
35 pkgver() {
36   cd $pkgname
37   git describe --tags | sed 's/^BIJIBEN_//;s/_/./g;s/[^-]*-g/r&/;s/-/+/g'
40 prepare() {
41   cd $pkgname
43   # Fix build with Meson 0.61
44   git cherry-pick -n 994af76ce5144062d55d141129bf6bf5fab002ee
46   # Remove libuuid dep
47   git cherry-pick -n cbadb5e8b7d3e5e6672e8acab82276c174999a12
49   # Soup 3
50   git cherry-pick -n 8471369c54f9aa777857e2a42d82ab502c071520
53 build() {
54   arch-meson $pkgname build -D update_mimedb=false
55   meson compile -C build
58 check() {
59   meson test -C build --print-errorlogs
62 package() {
63   meson install -C build --destdir "$pkgdir"
66 # vim:set sw=2 sts=-1 et: