1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
4 pkgname=qt5-networkauth
9 url='https://www.qt.io'
10 license=(GPL3 LGPL3 FDL custom)
11 pkgdesc='Network authentication module'
14 _pkgfqn="${pkgname/5-/}-everywhere-src-${_qtver}"
15 source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
16 sha256sums=('fcc2ec42faa68561efa8f00cd72e662fbc06563ebc6de1dc42d96bb2997acd85')
31 make INSTALL_ROOT="$pkgdir" install
33 # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
34 find "$pkgdir/usr/lib" -type f -name '*.prl' \
35 -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
37 install -d "$pkgdir"/usr/share/licenses
38 ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/${pkgname}