1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Anatol Pomozov <anatol.pomozov@gmail.com>
3 # Contributor: Joel Teichroeb <joel@teichroeb.net>
4 # Contributor: Jonas Heinrich <onny@project-insanity.org>
6 pkgname=double-conversion
9 pkgdesc='Binary-decimal and decimal-binary routines for IEEE doubles'
11 url='https://github.com/google/double-conversion'
15 source=(https://github.com/google/double-conversion/archive/v$pkgver/$pkgname-$pkgver.tar.gz)
16 sha256sums=('04ec44461850abbf33824da84978043b22554896b552c5fd11a9c5ae4b4d296e')
19 cmake -B build -S $pkgname-$pkgver \
20 -DCMAKE_INSTALL_PREFIX=/usr \
21 -DBUILD_SHARED_LIBS=ON
26 DESTDIR="$pkgdir" cmake --install build
28 install -Dm644 $pkgname-$pkgver/LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname