archrelease: copy trunk to extra-x86_64
[arch-packages.git] / easytag / repos / extra-x86_64 / PKGBUILD
blob3ad940491ff8fc35c43cd0d7336ff82caf4c7937
1 # Maintainer: David Runge <dvzrv@archlinux.org>
2 # Contributor: Guillaume ALAUX <guillaume@archlinux.org>
3 # Contributor: Kevin Piche <kevin@archlinux.org>
4 # Contributor: Aaron Griffin <aaron@archlinux.org>
5 # Contributor: dorphell <dorphell@archlinux.org>
7 pkgname=easytag
8 pkgver=2.4.3
9 pkgrel=6
10 pkgdesc="Simple application for viewing and editing tags in audio files"
11 arch=('x86_64')
12 url="https://wiki.gnome.org/Apps/EasyTAG"
13 license=('GPL2')
14 # TODO: add back opus, speex, libvorbis and opusfile when files do not get
15 # corrupted anymore
16 depends=('cairo' 'gcc-libs' 'gdk-pixbuf2' 'glibc' 'id3lib' 'taglib' 'wavpack'
17 'zlib')
18 makedepends=('appstream-glib' 'atk' 'flac' 'glib2' 'gtk3' 'harfbuzz' 'intltool'
19 'itstool' 'libid3tag' 'pango' 'python' 'yelp-tools')
20 options=('debug')
21 source=("https://gitlab.gnome.org/GNOME/${pkgname}/-/archive/${pkgname}-${pkgver}/${pkgname}-${pkgname}-${pkgver}.tar.gz")
22 sha512sums=('a14ce7432592e8430039f8960a9de70f49adf0a60bc4232e8d894b9cab09d72b8205dd1660a51718b655130a4cee69841106461df7d0b05b4b36b611398789e3')
23 b2sums=('dbb47f4f653da12e7b677a4757d60ad136d6281e075bdb74a57cab3d3848cb414dab67e3b0f463cabf8dcdeecf7dc193cfe9a52a8d9023b8b29025a9f2168d87')
25 prepare() {
26   mv -v "${pkgname}-${pkgname}-${pkgver}" "${pkgname}-${pkgver}"
27   cd "${pkgname}-${pkgver}"
28   ./autogen.sh
31 build() {
32   cd "${pkgname}-${pkgver}"
33   # disable ogg vorbis because easytag has a bug that corrupts files
34   # https://gitlab.gnome.org/GNOME/easytag/-/issues/8
35   # disable nautilus actions because it was not ported to nautilus 43
36   # https://bugs.archlinux.org/task/76338
37   ./configure --prefix=/usr \
38               --disable-ogg \
39               --disable-opus \
40               --disable-speex \
41               --disable-nautilus-actions
42   make
45 check() {
46   cd "${pkgname}-${pkgver}"
47   # tests claim that easytag.appdata.xml is not valid, but it is, so we touch
48   # the validation file
49   touch "data/${pkgname}.appdata.valid"
50   make -k check
53 package() {
54   depends+=('libFLAC.so' 'libatk-1.0.so' 'libid3tag.so' 'libgdk-3.so'
55   'libgio-2.0.so' 'libglib-2.0.so' 'libgobject-2.0.so' 'libgtk-3.so'
56   'libharfbuzz.so' 'libpango-1.0.so'
57   'libpangocairo-1.0.so')
58   cd "${pkgname}-${pkgver}"
59   make DESTDIR="${pkgdir}" install