archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gnome-characters / repos / extra-x86_64 / PKGBUILD
blobd0aa3d21b3ce209c0e25a33abe92cee2d5b26143
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=gnome-characters
5 pkgver=44.0
6 pkgrel=1
7 pkgdesc="A character map application"
8 url="https://gitlab.gnome.org/GNOME/gnome-characters"
9 arch=(x86_64)
10 license=(GPL2)
11 depends=(
12   emoji-font
13   gjs
14   gnome-desktop-4
15   gtk4
16   libadwaita
17   libunistring
19 makedepends=(
20   appstream-glib
21   git
22   gobject-introspection
23   gperf
24   meson
26 groups=(gnome)
27 _commit=9bbbe9fc4d62f1d7a642d504beb48df79b2e7ab5  # tags/44.0^0
28 source=("git+https://gitlab.gnome.org/GNOME/gnome-characters.git#commit=$_commit")
29 b2sums=('SKIP')
31 pkgver() {
32   cd $pkgname
33   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
36 prepare() {
37   cd $pkgname
40 build() {
41   arch-meson $pkgname build
42   meson compile -C build
45 check() {
46   meson test -C build --print-errorlogs
49 package() {
50   meson install -C build --destdir "$pkgdir"
53 # vim:set sw=2 sts=-1 et: