archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gnome-epub-thumbnailer / trunk / PKGBUILD
blob3e420f395215e1239fbfffb9e58994055a5e3d69
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=gnome-epub-thumbnailer
4 pkgver=1.7
5 pkgrel=1
6 pkgdesc="Thumbnailer for EPub and MOBI books"
7 url="https://gitlab.gnome.org/GNOME/gnome-epub-thumbnailer"
8 license=(GPL)
9 arch=(x86_64)
10 depends=(gdk-pixbuf2 librsvg libarchive libxml2)
11 makedepends=(git meson)
12 _commit=24829a20630ee5a004f00b5fdd3b6830f593503f  # tags/1.7^0
13 source=("git+https://gitlab.gnome.org/GNOME/gnome-epub-thumbnailer.git#commit=$_commit")
14 sha256sums=('SKIP')
16 pkgver() {
17   cd $pkgname
18   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
21 prepare() {
22   cd $pkgname
25 build() {
26   arch-meson $pkgname build
27   meson compile -C build
30 check() {
31   meson test -C build --print-errorlogs
34 package() {
35   meson install -C build --destdir "$pkgdir"
39 # vim:set sw=2 sts=-1 et: