archrelease: copy trunk to extra-x86_64
[arch-packages.git] / groff / trunk / PKGBUILD
blob578e489ddf13969f017215a0f33e30113c7f9242
1 # Maintainer: 
3 pkgname=groff
4 pkgver=1.22.4
5 pkgrel=10
6 pkgdesc='GNU troff text-formatting system'
7 arch=('x86_64')
8 url='https://www.gnu.org/software/groff/groff.html'
9 license=('GPL')
10 depends=('perl' 'gcc-libs')
11 makedepends=('netpbm' 'psutils'  'libxaw' 'perl-file-homedir')
12 optdepends=('netpbm: for use together with man -H command interaction in browsers'
13             'psutils: for use together with man -H command interaction in browsers'
14             'libxaw: for gxditview'
15             'perl-file-homedir: for use with glilypond')
16 options=('!docs' '!emptydirs' '!makeflags')
17 validpgpkeys=('2D0C08D2B0AD0D3D8626670272D23FBAC99D4E75') # Bertrand Garrigues <bertrand.garrigues@laposte.net>
18 source=("https://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz"{,.sig}
19         display-utc-times.patch
20         'site.tmac')
21 sha256sums=('e78e7b4cb7dec310849004fa88847c44701e8d133b5d4c13057d876c1bad0293'
22             'SKIP'
23             'b1e0bcbe1e0737aed1301066ff92a1e7fa0bd8b80a36321f92f519366a1acdb3'
24             'a2f4c5657595c5961c2c2b80e77b1126a2fc0a0caea5c0660b36255b3d85b7ff')
26 prepare() {
27   cd $pkgname-$pkgver
28   # always use UTC times for display - using localtime is problematic for reproducible builds
29   # fixes FS#69123 - patch taken from Debian
30   patch -Np1 -i ../display-utc-times.patch
31 }  
33 build() {
34   cd $pkgname-$pkgver
36   ./configure \
37     --prefix=/usr \
38     --with-x \
39     --with-appresdir=/usr/share/X11/app-defaults
40   make
43 check() {
44   cd $pkgname-$pkgver
45   make check
48 package() {
49   cd $pkgname-$pkgver
50   make DESTDIR="$pkgdir" install
51   
52   # add compatibility symlinks
53   ln -s eqn "$pkgdir"/usr/bin/geqn
54   ln -s tbl "$pkgdir"/usr/bin/gtbl
55   ln -s soelim "$pkgdir"/usr/bin/zsoelim
57   # FS33760 - TERMCAP variables not followed
58   # TODO: everyone is doing this - find out why upstream does not...
59   cat "$srcdir"/site.tmac >> \
60     "$pkgdir"/usr/share/groff/site-tmac/man.local
61   cat "$srcdir"/site.tmac >> \
62     "$pkgdir"/usr/share/groff/site-tmac/mdoc.local