archrelease: copy trunk to extra-x86_64
[arch-packages.git] / ibus-typing-booster / trunk / PKGBUILD
blob7b004afd1296ad79e777b408e8fba4b782d9a1f0
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=ibus-typing-booster
4 pkgver=2.22.5
5 pkgrel=1
6 pkgdesc="Predictive input method for the IBus platform"
7 url="https://mike-fabian.github.io/ibus-typing-booster/"
8 arch=(any)
9 license=(
10   Apache
11   GPL3
13 depends=(
14   ibus
15   m17n-lib
16   python-dbus
17   python-gobject
18   python-pyenchant
19   sqlite
21 makedepends=(git)
22 _commit=f3a0dec6546d631dada80654ad043466bbf317bc  # tags/2.22.5
23 source=("git+https://github.com/mike-fabian/ibus-typing-booster#commit=$_commit")
24 b2sums=('SKIP')
26 pkgver() {
27   cd $pkgname
28   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
31 prepare() {
32   cd $pkgname
33   autoreconf -fvi
36 build() {
37   local configure_options=(
38     --prefix=/usr
39     --sysconfdir=/etc
40     --localstatedir=/var
41     --libexecdir=/usr/lib/ibus
42   )
44   cd $pkgname
45   ./configure "${configure_options[@]}"
46   make
49 package() {
50   cd $pkgname
51   make DESTDIR="$pkgdir" install
53   cd "$pkgdir/usr/share/$pkgname/data"
54   gzip -nf --best *.{txt,json} annotations{,Derived}/*.xml
57 # vim:set sw=2 sts=-1 et: